APRS-Forum

Normale Version: APRScube von DL3DCW
Du siehst gerade eine vereinfachte Darstellung unserer Inhalte. Normale Ansicht mit richtiger Formatierung.
Seiten: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36
Im Prinzip könnte man sowas einbauen. Die Frage ist nur - wozu könnte das nützlich sein? Auch habe ich schon überlegt ob man nicht den GPS-Track aufzeichnen sollte. Wenn eine solche Funktion einen wirklichen Mehrwert bringt lasse ich mich gerne überzeugen. Auf der anderen Seite möchte ich aber auch nicht unzählige Funktionen einbauen die zwar technisch möglich sind aber nie oder nur sehr selten genutzt werden. Für gute Ideen bin ich aber natürlich immer zu haben ...
(24.04.2021, 09:06)DL3DCW schrieb: [ -> ]Im Prinzip könnte man sowas einbauen. Die Frage ist nur - wozu könnte das nützlich sein? Auch habe ich schon überlegt ob man nicht den GPS-Track aufzeichnen sollte. Wenn eine solche Funktion einen wirklichen Mehrwert bringt lasse ich mich gerne überzeugen. Auf der anderen Seite möchte ich aber auch nicht unzählige Funktionen einbauen die zwar technisch möglich sind aber nie oder nur sehr selten genutzt werden. Für gute Ideen bin ich aber natürlich immer zu haben ...

Guten Morgen,
ne, is klar, dass es immer eine Abwägung zwischen Nutzen und Aufwand ist....

Bei uns im OV ist gerade bisschen LoraAPRS-Fieber, ich hab ein paar angesteckt, die jetzt mit Trackern unterwegs sind und die
Empfangsbereiche ausloten, im APRS-IS sieht man ja immer nur die Pakete die vom "schnellsten" Igate übernommen wurden,
was mein eigenes IGate so an Trackern empfängt steht ja dann nur im Zähler auf dem Display, aber nicht wer, das denke ich wäre
schon interessant, auch zur Optimierung der Antenne / des Standortes etc.  für Gateways
wenn es mit der integrierten µSD schon ein gut zugängliches Speichermedium gibt, wäre es als Log natürlich klasse.

Was GPS-Tracks anbelangt, finde ich die Handhelds überlegen, da die Karte halt mit dabei ist
73 de DL3CK, Christof
Für solche Zwecke dürfte die SNR/RSSI-Funktion ganz gut geeignet sein. Einfach mal einschalten. Dann werden dem empfangenen Paket SNR/RSSI-Wert angehängt. Zudem wird dadurch die Duplikatsfilterung „ausgehebelt“ und somit sind alle Pakete im APRS-IS sichtbar. Allerdings würde ich das nicht dauerhaft eingeschaltet lassen sondern wirklich nur für Testzwecke verwenden.
Ahh, ok - Danke für den Tipp

PS: hast du noch Thermo/Baro Sensoren vorrätig?
73 Christof
Hallo Christof, ich habe Dir diesbezüglich eine PN gesendet.
Das erste 30dBm-Modul auf eigener Platine. Leider hatten sich ein paar unvorhergesehene Probleme ergeben.
In der Hoffnung das diese nun gelöst sind werde ich noch ein paar Tage testen um wirklich ganz sicher zu sein ...

[attachment=55]
(29.04.2021, 13:01)DL3DCW schrieb: [ -> ]Das erste 30dBm-Modul auf eigener Platine. Leider hatten sich ein paar unvorhergesehene Probleme ergeben.
In der Hoffnung das diese nun gelöst sind werde noch ein paar Tage testen um wirklich ganz sicher zu sein ...

Sieht sehr gut aus, viel Erfolg beim Testen
Hinweis zur aktuellen Firmware 1.2

Es gibt einen kleinen Bug der zu Problemen führt wenn der Info-Text in der "APRScube.ini" länger als 30 Zeichen ist. In dem Fall wird das Auslesen der INI abgebrochen und für die nachfolgenden Einträge werden die Standardeinstellungen übernommen. Somit erfolgt u.a. keine korrekte Anmeldung am APRS-IS da der Passcode falsch ist (Standardeinstellung 12345). Eigene und fremde APRS-Pakete (iGate) werden in dem Fall nicht weitergeleitet.

Abhilfe: Einfach die Textlänge auf 30 Zeichen begrenzen. Länger sollte der Text bei LoRa-APRS aber eigentlich sowieso nicht sein. Der Fehler wird in der nächsten Version behoben.
Servus zusammen,
hatte es bemerkt, konnte es aber leider an keiner konkreten Länge festmachen oder ob es an Leerzeichen hängt etc. ,
wollte nicht bei der 1W-Modul Testung stören.....
Over the Air ist kürzer natürlich besser - bei unserem Gateway haben wir noch den Link auf die OV-WebSeite mit drin als Werbung.....

Wenn du an 1.3 arbeitest hätte ich noch folgende Vorschläge falls machbar:

Im Gateway-Modus die Bakenzeit länger oder über .ini einstellbar (4x plus Werbeeinblendung ist mir fast zuviel)

ggf. auch getrennte Infos für Gateway und Tracker Modus - bei Tracker habe ich gerne mal ein "QRV 145.xxx" mit drin,
das ist beim Gateway-Modus wenn der Cube im Auto auf nem 4G-Hotspot läuft und ich im Umkreis mit einem anderen Tracker unterwegs bin dann eher Quatsch.

sonst läuft die 1.2 aber gut- habe nichts weiteres bemerkt.

was macht telemetry = on eigentlich?

Grüße Christof
Hallo Christof,

ich werde Deine Anregungen mit auf die Wunschliste nehmen. Mit der Funktion telemetry = on werden die Daten eventuell angeschlossener Sensoren (Thermo, Hygro, Baro) zusätzlich als APRS-Telemetrie ausgesendet.

Schönen Gruß
Frank, DL3DCW
Tach zusammen, ich habe da mal eine Frage zum WLan-Verbingung des APRScube. Ich bekomme zuhause mit der Fritz.Box und mit dem Samsung-A3 eine Verbindung aufgebaut, mit dem Huawei-Hotspot und dem iPhone 11 nicht, obwohl beide auf dem neusten Stand sind. Aufbauversuche zum iPhone sowie zum Huawei-Hotspot werden im Sekundentakt angezeigt und wieder abgebrochen. Ich verstehe es nicht....

Danke im Vorraus und mit den Besten Grüßen vom Niederrhein

Norbert
Hallo Norbert,

das Problem kann ich bestätigen. Mit den iPhones gibt es Probleme (ist auch bei mir so). Das ist aber nicht nur beim APRScube so sondern tritt manchmal auch bei anderen Geräten auf. Bei meinem Huawai-Hotspot kappt es hingegen absolut problemlos.

Eventuell kannst Du mal versuchen einen anderen Kanal zu wählen. Es hat sich gezeigt das Kanäle >= 10 manchmal Probleme machen. Sogar in Verbindung mit den FritzBoxen.

Schönen Gruß
Frank, DL3DCW
Hallo Frank,

vielen Dank für die schnelle Antwort. Beim iPhone gibt es ja öfters Probleme, ist zwar schade, aber nicht lebensnotwendig.
Mit dem Huawei-Hotspot funktioniert es jetzt auch einwandfrei.

Danke nochmal und eine schöne Woche

Norbert, DD4JN
Super, danke für die Rückmeldung!
Ich habe einige QRO-Module als SMD-Komplettbausatz zusammengestellt. Alle Vorbesteller bekommen
in der nächsten Woche Post. Darüber hinaus steht eine ausreichende Anzahl an Bausätzen zur Verfügung.

[attachment=56]

SMD-Komplettbausatz für das QRO-Modul

[attachment=57]

Sämtliche Teile sind im Bausatz enthalten

[attachment=58]

Beide Seiten eines fertig aufgebauten QRO-Moduls
Hallo Frank,

danke für deine tolle Software für den M5Stack! Der Aufbau des QRO-Moduls war kein Problem, heute hab ich endlich auch die GPS-Module bekommen und DL3BH-15 hat die ersten paar Kilometer mit mir im Auto zurückgelegt.

Vorher hatte ich jedoch ziemliche Probleme mit dem Lesen der Konfig von der SD-Karte, ich hatte eine alte 2 GiB SanDisk und eine 16 GiB SanDisk Ultra 10, die wollte mein Core nicht lesen. Ich habe dann weitere Karten besorgt und Tests mit einem zweiten Core von mir und zweien von DB4TA gemacht, da gab es Karten, die gar nicht, nur auf einem oder auf allen Cores liefen. Manche funktionieren mit dem Selbsttest-Programm nicht nach einem kurzen Reset sondern erst nach einem Kaltstart. Verbunden mit der Auskunft vom Support, dass zwischen den Versionen etwas an der Stromversorgung geändert wurde lassen mich vermuten, dass hier womöglich etwas mit der Ansteuerung der Resets etwas nicht stimmt, die kommt ja üblicherweise auch vom PMIC, und manche Karten da zickig reagieren.

Bevor ich mich da weiter reingrabe, hat hier sonst noch jemand ähnliche Erfahrungen gemacht?

73,
Holger
Hallo Holger,

danke für die nette Rückmeldung. Ich selbst habe inzwischen schon recht viele Cubes aufgebaut, Probleme mit den Speicherkarten hatte ich dabei bisher noch nicht. Wohlmöglich liegt es aber daran das ich bisher ausschließlich Core Gray aus aktueller Produktion sowie nur zwei unterschiedliche Speicherkartentypen (Intenso und Kingston mit jeweils 8GB) verwendet habe.

Ist das Problem bei Dir vielleicht nur in Verbindung mit dem QRO-Modul aufgetreten oder ist es davon völlig unabhängig?

Schönen Gruß
Frank, DL3DCW
Das Problem ist unabhängig vom QRO-Modul, am Ende hab ich es nur mit Core und Base probiert.

Ich habe einen Core v2.4 mir Datecode(?) 1220, der ist zickig, und einen 2.4 mit 1420, der schluckt alles.
Getestet habe ich weiterhin Transcend 4GB Class 10, Transcend 8GB Class 4, Intenso 4GB Class 4, Intenso 8GB Class 10, die laufen auf beiden Cubes problemlos.

Beim 1420 mit Serien-LoRa- und GPS-Modul laufen SanDisk 2GB und SanDisk Ultra 16GB 10 im Selbsttest nur, wenn vorher der Einschaltknopf mindestens 2s gedrückt wird, ohne Module kein Problem.

Ich hab gerade auch noch Schwierigkeiten, in mein WLAN zu kommen. FritzBox 6360 Gastzugang, den WLAN-Kanal hab ich extra von 11 auf 6 umgestellt, Passwort ohne Leerzeichen. Auf meinen Handy-Hotspot hat er sich gleich verbunden. Ist gerade aber nicht meine Prio, mein iGate läuft auf nem TTGO, der Cube braucht erstmal kein LAN, obwohl es natürlich für Updates und Konfiguration komfortabler wäre.

Jetzt bin ich erst einmal gespannt, was das 1W mir im Vergleich zum T-Beam an Reichweite bringt Big Grin
Ok, danke für die Info. Wenn Du bereits schon nur mit Core/Base Speicherkartenprobleme hast kann es ja eigentlich nicht primär an den Zusatzmodulen liegen. Wenn ich Dich richtig verstanden habe scheinen auch nur die SanDisk-Karten (abhängig vom Core) Probleme zu machen, oder?

Wenn auf machen Cores die SanDisk-Karten nur in Verbindung mit dem Standard-18dBm-LoRa-Modul "zicken" könnte das auch am SPI-Bus liegen (warum auch immer). Denn Speicherkartenleser und LoRa-Modul (zudem auch noch Display etc.) hängen alle an dem Bus. Ich hatte diesbezüglich anfangs Probleme mit Display und einigen NiceRF-LoRa-Modulen. Das konnte ich durch die drei Serienwiderstände in den SPI-Leitungen auf dem QRO-Modul lösen. Alle von mir bisher aufgebauten/getesteten Cubes laufen damit einwandfrei.

Zum WLAN-Problem: Hier ist es vor allem wichtig das der WLAN-Name/SSID keine Leerzeichen/Sonderzeichen enthält. Zudem dürfen die Zeilen in der Konfigurationsdatei im Moment nicht länger als 28 Zeichen sein (ist ein Bug der in der nächsten Version behoben wird). Im Zusammenhang mit dem FritzBoxen gibt es (manchmal) Verbindungsprobleme auf den oberen Kanälen. Und iPhone-Hotspots mag der M5Stack wohl auch nicht.

Die Abdeckung/Reichweite hat sich bei mir mit dem QRO-Modul spürbar verbessert. Die Tracks sind damit - wir haben hier allerdings auch eine gute iGate-Dichte - fast lückenlos. Ich möchte nicht mehr darauf verzichten Wink
Hallo,
per ftp kann ich den Cube nicht erreichen - Ist die Kombination aus Passwort und Benutzer die gleiche wie beim Webinterface?
Vy73 de
Rolf, DL8BAG
Seiten: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36